AVS4You.comSupportRulesAbout Us
    ENG English    FRA Français    DEU Deutsch
Posts: 3
Registered: 13.07.2008
28.11.08 16:20:35
To: pinocchio35745

I had the same issue and did the same thing you did. the old 5.x version of Video Converter works. I had installed 6.2 and got the EAccessViolation error. I did the full uninstall and even the registry cleaner. support told me to uninstall and reboot and then re-install and re-license. did not fix either.

so I am stuck on 5.x also. all other AVS software seems to work no problem. it must be something with the 6.2.x version of Video Converter.
Posts: 12
Registered: 27.11.2008
29.11.08 01:28:25
To: zebtar99

Hello zebtar99,
good to know that someone else has the same problem as me. This proves, that not me is doing something wrong ;-)
I am in contact with the AVS support center and hope to get some more info next week. As soon I have news I will post them here as well.
Since I have really removed everything related to AVS SW before reinstallation I am quite convinced that there is a problem with the new VC 6.2 version.
Today I will try to install VC 6.2 on another PC to find out, if I have a general problem or if it depends on the specifics of my current PC.
I have read in the internet related to this error that there may be a relation to an incompatibility of dll s. It seems to be a typical MS error return code, which is not AVS specific.
Therefore I have provided information to AVS which type of other 'video related' SW is installed on the PC with the problem.

See you, pinocchio35745
Posts: 569
Registered: 16.05.2008
01.12.08 01:10:53

We are very sorry for the inconvenience occurred. The main problem is, that we can not reproduce this error.

So, we need as much information, as possible.

First, please inform us about audio/video codecs, installed on your PC's. For that:
Start >> Control Panel >> System >> Hardware >> Device Manager >> Sound, video and game controllers >> Video Codecs >> Properties and the same with audio. Please send us a screenshot of the codecs, installed on your PC

To make a screenshot, please,
- press PrtScn to copy the screenshot to the clipboard
- open a graphics editing program (e.g. Microsoft Paint, select Start\Run..., enter 'mspaint' and press OK to start it)
- press Ctrl+V to paste the screenshot from the clipboard
- save the image in PNG format
- attach the image file to the post

Second. Please, try to delete AVS Software navigator and launch Video Converter again.

Hope to hear from you soon.
Posts: 12
Registered: 27.11.2008
01.12.08 10:40:06
To: Dam

Hi Dam,

I am in contact with your colleague Alexey Micheev from the AVS4YOU Support staff.
Some minutes ago I've sent him my video codec information as PDF. He did not yet ask for the audio codecs as well ;-).
If required I can do this also.

I checked also if something changes if I remove the AVS SW navigator, but no positive effect. So I can still start all other AVS video application programs except VC 6.2.

B.T.W. I have a nice freeware tool called AVIcodec, from which you can get a lot of details about the installed versions and location of video codecs & filters.

Attached the same file I've sent to Alexey (incl. the screen shots from AVI Codec)

If you require further info feel free to ask :-)

regards pinocchio35745
Attached files:
Posts: 12
Registered: 27.11.2008
01.12.08 12:17:50
To: Dam

Hi Dam,

some additional information.

Now I tried to install VC6.2 on a VISTA SP1 PC where no AVS SW was never installed before.
Installation went fine and VC6.2 was started after finish of installation process.
Off course immediately the pop-up was shown to register the SW and the Web-Site was displayed.
Then I closed VC6.2 and activated AVS SW with the AVS registration program.
The licence information was successfully placed in known path program data\avs4you\licence
Then I tried to start VC6.2 again and received immediately a pop-up screen with some strange characters and an ok button.
Whatever I do now I can not get VC6.2 running on this PC again.
So I tried already uninstallation, renaming/removing licence path/clearing registry entries, nothing helps

Hopefully this gives you another idea, what might happen...

regards, pinocchio35745
Posts: 12
Registered: 27.11.2008
01.12.08 12:56:22
To: Dam

and here the probably most important info from today !:-P*DANCE*
I tried several times to start VC6.2 on the VISTA PC with the reinstalled version w/o yet having activated the SW.
Two times out of about 15 tries I managed to get it started ! (while in all other cases I saw the famous pop-up ok button only)
So for me it looks like a run-time issue more and more.
Have you ever tested your SW on a relatively old computer ?
On both PCs where I encountered those problems I am using 'old' single core AMD XP processors. The WinXP PC is equipped with a 2800+ AMD XP (Barton) and the VISTA PC is equipped with a 2800+ AMD Sempron...
Posts: 569
Registered: 16.05.2008
02.12.08 07:11:01
To: pinocchio35745

Thank you very much for the information provided.

He did not yet ask for the audio codecs as well

We will be very obliged to you if you send us audio codecs information as well.
Posts: 12
Registered: 27.11.2008
02.12.08 11:59:14
To: Dam

Hi Dam,

here the audio codec information as requested. Both video & audio codecs are taken from the PC with XP installed.
F.Y.I.: if I can get VC 6.2. started on the VISTA PC as described before, then it seems to run w/o problems. At least I was able yesterday to convert a 1 h video from mkv format to avi.

Hope that you soon will have concrete recommendations how to solve the EAccessViolation bug.
B.T.W. is the EAccessVoilation bug on XP the same as the pop-up with strange characters bug seen on VISTA or do you think this are two different ones ?

see you, Georg
Posts: 569
Registered: 16.05.2008
09.12.08 03:21:23
To: pinocchio35745

Hi Georg,

Thank you for the provided information.
We are studying it at the moment. As we work together with avs support team, we will contact you via support system with a possible solution.

Best Regards
Posts: 12
Registered: 27.11.2008
10.12.08 02:48:38
To: Dam

Hi Dam,

thanks for the information. Hopefully you will find a solution soon ;-)
Here my latest infos about 'playing around' with VC 6.2

PC1 with WinXP SP3 installed: still 100% the EAccessViolation problem as described in this post and were you received the audio/video codec versions screen shots

PC2 with VISTA SP1 installed: same message box as described in post 'Video Converter 6: message box ".>@>1/24.&$í"' started by VCGuitar. If I try to start VC 6.2 several times I can get VC 6.2. working in about 1 out of 10 trials. If it starts then it runs w/o problems

PC3 with WinXP SP3 installed: Here VC 6.2. runs w/o any problems so far :-). The basic SW installation of this PC is quite similar to PC1 but in total less SW programs installed.

So if you are interested in additional information on PC1 vs PC3 for comparism I can hopefully provide what you need.

Best regards, Georg
Posts: 569
Registered: 16.05.2008
19.12.08 01:08:00
To: pinocchio35745

Hi Georg,
We are very thankful to you for the information.
But we will also much appreciate if you send us the audio/video codecs of the rest two PC's. That will allow us to compare them and make some resume.

Posts: 2
Registered: 20.12.2008
20.12.08 21:27:32
It seems to me that many of your customers, including me, are experiencing exactly the same problem. I am concerend about the fact that your crack team can't seem to reproduce it.

You're software is useless on my machine. I, like others, paid for a unlimited subscription.

I've tired everything a user with over 40 years computing and 28 years desktop computing experience could try.

It's not me, and it's not my machine.

By the way, to make matters worse, I just tried to recover my license key using the email address I registered with, and you confirmed in an email.

Your registration system didn't recognize me. I found that even more frustrating.

You guys are on the verge of a software revolt that could go viral if you let it. Trust me, this is not about audio and vidoe codecs.

Why don't you see what you can do to get this problem fixed as soon as you can.
Posts: 2
Registered: 20.12.2008
21.12.08 12:15:06

I got a message from support this morning, they suggested I try the following (in their words)...



To avoid the problem please completely uninstall AVS4YOU software from your PC. Instructions below:

1. Go Start> All Programs> AVS4YOU> Uninstall.

2. Go Start> Run... Print regedit in the opened window and click Ok. In the opened Registry Editor window please find and delete all AVS4YOU folders.



3. Go Local Disc (C:) > Program Files > AVS4YOU (delete it).
Go Local Disc (C:) > Program Files > Common Files> AVSMedia (delete it).
Go Local Disc (C:)>> Documents and Settings>> All Users>> Application Data>> AVS4YOU (delete it).

Now install the program anew on your PC.


I run Windows Vista. I think the instructions above are for Windows XP. Some of the instructions above didn't apply to Vista. So, instead, I did the following, and it worked for me:


Navigate to (C:) > Program Files > AVS4YOU

Open the UNINSTALL application.

Check all the boxes, and click UNINSTALL.

Close all the windows.


Start the RUN command. In Windows Vista you can access the RUN command by pressing the Windows Logo Key + R

Type "regedit" in the opened window and click OK. In the opened Registry Editor window please find and delete all AVS4YOU folders.


Delete the file HKEY_CURRENT_USER > SOFTWARE > AVS4YOU (delete it).


Open a Windows Explorer Window and

Delete the file (C:) > Program Files > AVS4YOU
Delete the file (C:) > Program Files > Common Files> AVSMedia
Delete the file (C:) > Users > All Users > AVS4YOU
Delete the file (C:) > Users > (your user name) > Documents > AVS4YOU
Delete the file (C:) > Users > Public > Public Documents > AVS4YOU

Reinstall one of the AVS Programs, start it, and register it.

Good luck.
Posts: 1
Registered: 30.12.2008
01.01.09 10:26:27
To: drkdezires

I finally got the software to work with XP SP3, try dowmloading this CODEC Pack, I installed it and now the Conversion software works! http://rapidshare.com/files/169891728/XP-Codec-Pack-2.4.4.rar
Posts: 12
Registered: 27.11.2008
11.01.09 08:53:54
To: Dam

Hi Dam,

1st of all sorry for my late response. I was on holidays over Xmas and therefore it took some time to respond.

Current status is as follows:

PC1 XP SP3: Still the same problem with Video Converter 6.2 (EAccessViolation) . The list of video and audio codecs I have sent already before.

PC2 Vista SP1: VC 6.2 runs in 1 of 5 trials to start it as decribed before. Here I can not send any useful video / audio codec information as there is nothing listed in the Vista Control Panel about codecs. If you know a place where I can find this info I can send it later on.

PC3 XP SP3: All AVS SW runs so far w/o a problem except I was forced today to buy a 2nd license as I am not allowed to run AVS SW on more than one PC....here I had then a lot of trouble with the license server to get the new license activated, but now it seems to run. I have attached the codec information of this PC as requested.

I asume that I will soon run into license troubles with the Vista PC as well. So if you want me to do further testing I would be happy if you could do something about this. I can not afford buying a 3rd license just for testing...;-)

If I look to the latest post of ws556 it seems to confirm that there is a codec issue behind the EAccessViolation bug.

regards Georg
Attached files:
Posts: 1786
Registered: 22.01.2009
13.02.09 01:20:26
To: jimbozs2000

Your post has been moved. Please follow the link.
Posts: 2
Registered: 22.02.2009
22.02.09 11:59:44

After sending 3 e-mails to the support desk & receiving absolutly no replies, I have found this forum with people who have the same problem as me.

I am currently experiencing problems accessing the converter program. Once I have clicked on the converter icon, I am
getting the error message "EAcessViolation", which will not let me enter the programme.
I have tried repairing the programe via the AVS repair tool & all applications say "sucess",
except "avsmobiledevice2activesync.dll" which says "can't load library".

The problem stll persists so I uninstalled & re-installed the program from the website 3 times, but I am still getting the
same error message. I also tried the advise given to "drkdezires, but can not find a file named "License"

Any help would be greatly appreciated
Posts: 1786
Registered: 22.01.2009
24.02.09 05:06:49
To: adamsapples

Please provide us with the information on video and audio codecs installed on your PC.

If you are using Win XP, you can find them following the steps below:
- right-click on My Computer icon on your desktop and choose Manage;
- in the window opened choose Device Manager on the left, then Sound, Video and Game Controllers on the right (double-click it);
- double-click on Video Codecs, choose Properties and make a screenshot of this window;
- do the same for Audio Codecs and attach the screenshots here.

If you are using Win Vista, you can find codecs following the steps already specified above by Dam.

Posts: 2
Registered: 22.02.2009
03.03.09 02:04:10
To: nadin

Many thanks for getting back to me, I finally received an answer bach from the helpdesk,but I found it easier to reformat the pc. Bit drastic, but I didn't have anything on the hard drive anyway. I have copied the helpdesks responce below incase this would help anyone in the future.

Thanks again

In order to solve the problem
we advise you to update the codecs installed on your PC.

You can download the free K-Lite Codec Pack:

If it doesn't solve the issue, please contact us again and provide the
information on the codecs installed on your computer.

If you have Windows XP OS you can find them following the steps below:
- right-click on My Computer icon on your desktop;
- choose Manage;
- in the window opened choose Device Manager on the left, then Sound, video
and game controllers on the right (double-click it) > Video Codecs
- double click on Video Codecs, choose Properties and send us a screenshot
of this window.

If you have Windows Vista, please find codecs following Start > Programs >
Accessories > System Tools > System Information and choose there Components
> Multimedia > Video Codecs. Make a screenshot of this window.

Thank you in advance for the information. We will do our best to help you
as soon as possible.
Posts: 1786
Registered: 22.01.2009
16.03.09 03:59:01
We have found a possible way to clear up the EAccessViolation issue. So in case you get this error it would be great if you did some testing on your PC. This would help to find out 1) whether this is the codecs issue, 2) which codecs are causing the error.

1) To get an answer to the first question, you need to unregister the following two .dlls: AVSAVIFile3.dll and AVSWMVFile3.dll.

Follow Start > Run and copy-paste the following line into the field "Open":
regsvr32 "C:\Program Files\Common Files\AVSMedia\ActiveX\AVSAVIFile3.dll" /u

After that the DllUnregisterServer message will appear. Click OK.

Then follow Start > Run once again and copy-paste the following line:
regsvr32 "C:\Program Files\Common Files\AVSMedia\ActiveX\AVSWMVFile3.dll" /u

2) Launch AVS Video Converter (it must work fine, only To AVI and To WMV conversion will be disabled). In case the EAccessViolation error does not pop up this means that the problem was caused by the codecs. And vice versa, in case the error occurs, this was not the codecs issue. At this point please write back on the result!

3) In case the EAccess Violation error does not occur when lauching AVS Video Converter, please register AVSWMVFile3.dll first.

Run the following command:
regsvr32 "C:\Program Files\Common Files\AVSMedia\ActiveX\AVSWMVFile3.dll"

4) Start AVS Video Converter. If there is no error the problem must be connected with AVI and its codecs. If the error pops up this must be WMV problem. Please inform us on the result and we will try to find out which codecs exactly are causing the error.

Best regards
Users:  1  Perrywalton
Guests:  256