AVS4You.comSupportRulesAbout Us
    ENG English    FRA Français    DEU Deutsch
Posts: 2
Registered: 21.02.2020
21.02.20 15:15:31
I recently had a hard drive fail on me and sent it out for recovery. The recovery was successful. I tried to open AVS4YOU Video Editor and got the message" Class not registered...., etc.". This was a version I've had since 2010. I deleted the program and downloaded a new version, but with the same results. Can someone help me with this?
Attached files:
60.59 KB
Posts: 251
Registered: 08.09.2009
21.02.20 16:07:51
It is the ClassID of our AVSCommercialDetection.dll. This DLL may be corrupted or unregistered.

To repair AVS files please follow the instruction below:

1. Close all AVS programs and other running applications.

2. Copy the following link to the address bar of My Computer (This PC) window (or Run window - Windows+R) and press <Enter>:

If you run 32-bit Windows: %COMMONPROGRAMFILES%\AVSMedia\ActiveX\Repairing.exe

If you run 64-bit Windows: %COMMONPROGRAMFILES(x86)%\AVSMedia\ActiveX\Repairing.exe
Posts: 2
Registered: 21.02.2020
21.02.20 18:25:39
Thanks, that fixed it.
Users:  0  
Guests:  67