AVS4You.comSupportRulesAbout Us
    ENG English    FRA Français    DEU Deutsch
Posts: 7
Registered: 19.08.2011
13.02.12 04:18:50
I have come across a problem when using either the AVS Audio Converter or the AVS Audio Editor when producing MPEG1 Layer 2 audio files (ie mp2/mpa)
The versions of the products that I am using are listed below
Audio Converter version 7.0.3.485
Audio Editor version 7.0.3.422

I am running these applications on the latest Windows 7 64 bit Home Premium operating system

The mp2 files produced by either application are not recognised by TxMuxer, Imago or MuxMan MPEG multiplexers but the files can be played using Microsoft Media Player.

The problem can be overcome by editing the mp2 file with a HEX editor (I use HxD HEX editor http://mh-nexus.de/en/) and removing the ID3 header that contains information about the company that presumably wrote the Audio packages. After this ID3 info is removed then the above multiplexer programs have no trouble accepting th mp2 file.

The Audio Converter package does allow editing or inclusion of ID3 tag meta data but does not have an option to stop the
Posts: 7
Registered: 19.08.2011
13.02.12 04:23:38
To: Gantos20

I missed some text, the ID3 tag data is as follows ID3.......TYER.......ÿþ0.TRCK.......ÿþ1.WXXX........http://www.avs4you.comTENC...5...ÿþO.n.l.i.n.e. .M.e.d.i.a. .T.e.c.h.n.o.l.o.g.i.e.s.
I presume that ID3 tags are something that were indtroduced by third parties for mp3 files and not something that is expected in mp2 files hence the problems with the multiplexer programs.
Can option be introduced with new versions of the Audio Converter and Audio Editor to overcome inserting any ID3 tags or alternatively have the ID3 tags inserted at the end of the mp2 files after the audio data?

best regards Gantos20
Lex
Administrator
Posts: 914
Registered: 20.05.2010
13.02.12 07:54:28
To: Gantos20


Hello,

Please zip and send us the created mp2 file.

Best regards.
Posts: 7
Registered: 19.08.2011
13.02.12 09:27:35
To: Lex

Thanks for the prompt response Lex, I have attached the first 656kbytes of the audio file, the file itself is too big at 168Mbytes to send.

The ID3 header tags seem to be the culprit as I have said before, if I strip off the ID3 info the file is then acceptable to my other programs. The audio source is from a direct to air digital broadcast in Australia, the audio quality of the original had not been cleaned up so I used the AVS audio editor to correct the frequency response. The original digital recording was in AC3 format but the easiest way to re-mux back to a DVD format is to use mp2.

I did save the audio file directly from the AVS Audio Editor in mp2 format and struck the problem then I used the AVS audio converter to convert from a WAV version but it produced the same result as the AVS Editor, that is the ID3 tag was also inserted.
Attached files:
Lex
Administrator
Posts: 914
Registered: 20.05.2010
14.02.12 08:08:54
To: Gantos20


Hello,

Unfortunately, there is no possibility to convert audio without tags. We advise you to use a multimedia player (for example Aimp or Wnamp) to remove tags from an audio file.

Best regards.
Online:
Users:  0  
Guests:  256