AVS4You.comSupportRulesAbout Us
    ENG English    FRA Français    DEU Deutsch
Experienced User
Posts: 119
Registered: 01.01.2009
04.11.10 04:57:50
Hi

I've been experimenting with multipass conversions for the first time, but with no success. Codecs used: MPEG-4 (DivX/XVid) and H.264. See screenshot for settings.

The conversion completes first pass every time, so never a second pass.

The Stat file doesn't get written anywhere, even if I change the location manually. Should there be a forward slash in the path/name?

Help please...

James
Attached files:
Posts: 2396
Registered: 29.01.2012
05.11.10 06:58:21
To: jcthomson

James,

As far as I can see the path to Stat file is correct. Cannot guess what causes the problem... I would say there is glitch. Please try reinstalling AVS Video Converter (by the way we have just released the update 7.0.3.453) and then run repair.

I hope it helps.

Regards.
Experienced User
Posts: 119
Registered: 01.01.2009
06.11.10 09:59:39
To: Vlad

Vlad, I did as you suggested - uninstalled VC, deleted the registry files and programme folder, and re-installed latest version (which is the one I had anyway), ran repair.

Tested a short clip a few times with different settings, and still no success - clip converts first pass every time.

Also, the slash, forward or back, is definitely not allowed as part of a file name in Windows. I entered a legal path and file name and it wrote to disc ok.

Please see the attached screenshot for the details.

Everyone says two-pass conversion is definitely worth the extra time in terms of video quality, so I'd really like to get this working...

best

James
Attached files:
Posts: 2396
Registered: 29.01.2012
10.11.10 05:31:05
To: jcthomson

Hello James,

Thank you for getting back to us.

We have tested the program with the default path. There may be a problem with the default path working on vista. You should run AVS Video Converter as administrator in this operating system to have enough rights to create a file in the root directory drive C:

We will correct the path (also the slash) in the next version. Untill there is the following solution - enter your own path and save these parameters as your own profile (Advanced>Save Current Setup as Profile).

Best regards.
Experienced User
Posts: 119
Registered: 01.01.2009
15.11.10 04:44:10
To: Vlad

Hello Vlad

It's not a Vista problem.

I'm automatically an Administrator.

I did enter my own path - as I demonstrated in the attachment - and multipass still did not work. It completed the conversion after the first pass every time.

I'm not happy with these non-answers.

James
Posts: 2396
Registered: 29.01.2012
16.11.10 07:58:36
To: jcthomson

Hello James,

As far as I can see in your last screesnot, stat file is created successfully if you change the path. So, stat file is not the issue.


jcthomson:
It completed the conversion after the first pass every time.
I suppose you mean the fact that our program creates output video file after first pass, do you? This is exactly how the things must go in new version. After the second pass AVS Video Converter re-writes this first video file with the new one of better quality. You can check it for yourself comparing first and second output files - their quality and size will be different.

Regards.
Experienced User
Posts: 119
Registered: 01.01.2009
18.11.10 05:12:21
To: Vlad

Right. I did not know that the guidance document I was using had been superseded. The one I referred to said that the first pass would NOT write a video file to disc - that would happen only after the second pass. More pop up messages might avoid this confusion, eg "after first pass a file will be written and updated after the second pass". Just a suggestion.
Posts: 38
Registered: 12.05.2011
12.05.11 07:43:42
Hello,

I'm encountering the same kind of problem.

I wish to convert a .mov file into an .avi in multipass for a better quality too.

The 1st pass goes well and I end up with a low/medium sized file as planned.
But when I go for the 2nd pass, I get straight away an error message saying (roughly translated from my french version) "Impossible to convert by using selected output settings. Change the settings or use one of the presets."

My output settings remain the same between the 1st and 2nd pass, and I save them under the same directory. I give different names to the 2 passes, which seems a normal thing to do to me.

Just like James, I noticed that the stat file wasn't saved anywhere (unlike Virtual Dub for instance) and thought the issue could come from there.

But frankly, I'm lost at this point ; it'd be great if someone had an idea how to solve this (probably simple) problem.

Thank you,

Fañch
Experienced User
Posts: 119
Registered: 01.01.2009
13.05.11 11:54:22
To: Fañch

Hi Franch

this is the way to use the multipass facility:

1. select the input file; set the Output File Name; if you need to edit the input file before conversion, do so now
2. in the Advanced panel select your settings
3. in the Advanced panel, click the Advanced button - a codec settings window opens (see file multipass - first pass.pdf); Encoding Type = Multipass - First Pass; Stat File - type in the exact location for the temporary files which VC7 creates - this must be exact; click OK;
4. click Convert NOw!; the first pass will run
5. when the first pass is complete, you will see the message as in multipass - end of first pass.pdf; click Close (you can look at the file if you want to, but you don't have to)
6. in the Advanced panel, again click the Advanced button and select Multipass - Nth Pass; the Stat file should be as before - see multipass - second pass.pdf; click OK
7. click Convert Now! you will get the message shown in multipass - second pass 2.pdf; click Yes; the second pass will run
8.when the second pass is complete the message shown in multipass - end of second pass.pdf will appear; You are finished.

The Stat files should be save where you specified; I usually delete them when I'm finished; you can always use this setting for every multipass conversion, you don't need to change it.

Please let me know if you have any problems.

Best wishes

James
Posts: 38
Registered: 12.05.2011
27.05.11 05:25:29
To: jcthomson


Hi James,

- and thanks a bunch for the fast, clear and detailed reply. I only got back yesterday on the matter, that's why I'm only replying now.

Anyway, I had started to revert you after having followed the indicated steps and ended up with the same result.
I used to get stuck on step 7 : I was getting the message that says the 2nd pass is going to overwrite the 1st (it seems I was wrong then at first by typing a new name for the 2nd pass), I was hitting yes. But when I clicked Convert now!, the program wouldn't run and poped up the same error message as before.

I'm saying "I used to" since it's not anymore, as I actually went backwards in me quest for a working software :-(

To make a long story short, I used to be able to convert (from .mov to .avi) at least by a single pass and I was already quite happy with the result. Anyway, I did some cleaning lately in my codec settings on my PC (something had gone wrong with another software, and I finally got it working again - and even better). And since then, I can't convert to avi at all, should it be 1 or 2 pass conversion. I mean I can, but the file won't play at all.

Thus I decided to post a new topic -> http://forum.avs4you.com/posts.aspx?lng=ENG&t=839&p=1#15282
It's probably better to solve that issue before going forward again with my 2-pass issue. So I'll post back here as soon as the a.m. topic is solved.

Of course, if this new issue makes you think of some particular problem, feeel free to let me know..

Thanks again for your concern,

Fañch
Posts: 38
Registered: 12.05.2011
27.05.11 11:27:24
To: Fañch


Nevermind the single pass. Here's the screenshots I get for the two-pass conversion...(they remain the same anyway, even back when the single pass worked out fine).

F.
Posts: 38
Registered: 12.05.2011
27.05.11 11:35:14
To: Fañch


Just noticed one thing : the stat file renames itself "h264-1.pass" after the 1st pass is done (instead of remaining h264.pass as I think it should).

Since this stat file bears its original name (h264.pass) in the soft, I tried to rename it (as h264-1) but same result. And error message again when I renamed the saved stat file on my pc as h264 - it failed.
Posts: 2396
Registered: 29.01.2012
30.05.11 06:46:13
To: Fañch

Hello,

It's better not to rename .pass file and even make any manipulation with it. Also try reducing bitrate and frame rate in output settings for conversion.

Best regards.
Posts: 38
Registered: 12.05.2011
31.05.11 03:07:08
To: Vlad


Hi Vlad,
Thank you for your opinion on the question.

Before all, just wanted to say that I got the single pass working again in H264. Don't know how it came back but it did.

Now back to the 2-pass encoding :

As you recommended, I ran a couple of tests without manipulating anything (no changes in default folder, no renaming, no nothing).
I also lowened the bitrate from 2500 down to 500 and the framerate from 25 fts down to 10 fps.
It led to no changes though - see screenshots (couldn't attach more than 670 MB [or more than 5 files] here but the error msg screenshot I wanted to add is the very same than the one I uploaded previously.

N.B. Statfile doesn't show anywhere on C:/ when looking for it...

N.B. Choosing the MPEG4 video codec instead of H264 makes the 2nd pass running fine...even with maximum bitrate and original framerate (50 fps).

P.S. I was wondering : is one supposed to be able to play a 1st-pass encoding? I mean I know I can't in VirtualdubMod, but here, I actually can.
Posts: 2396
Registered: 29.01.2012
01.06.11 07:00:00
Hello,

We have just released new version of AVS Video Converter which can be downloaded from this link. Try using it. Please completely reinstall all AVS programs using the instructions here. Also, if stat file is not created, try choosing another directory instead of root directory C:\ .

Best regards.
Posts: 38
Registered: 12.05.2011
02.06.11 04:09:56
Hello,

The stat file doesn't show when set on default settings (c:/h264.pass) but shows when directed to an inner folder of c:/ (to eventually change its name itself into "h264-1.pass(.temp).

Anyway: I followed the instructions given in the link and got rid of every trace of AVS on my computer.
I installed the new version (8) and ran it with the wanted settings.

I changed the advanced settings back to default's, ie. back to c:/h264.pass and 800 bitrate. The 1st pass ran, fairly quickly (average bitrate), and ended up with a typical 1st pass size (as for such a bitrate) of 1/8 of the original .mov file.
-> I then selected Multipass N-pass, overwrote the 1st pass and again the error msg appeared (screenshots).

Same result when changing the output folder of both stat file and 1st pass to c:/Users/Me/Videos/...

I'll save the stat file on another directory than C:/ later today, see how it goes and will let you know.

N.B. In the set up of the 8th version, there was no possibilities offered to select additional tasks like the "windows media format 11 series runtime files" or any of the above as shown here for previous version (7).

Kind regards.
Posts: 38
Registered: 12.05.2011
02.06.11 04:14:26
Screenshots...
Attached files:
66.83 KB
Posts: 38
Registered: 12.05.2011
03.06.11 00:39:57
Hi again,

I tried on an external hard drive (G:/) and same result.
Same sad screenshots...
Attached files:
65.75 KB
Posts: 2396
Registered: 29.01.2012
07.06.11 02:01:28
To: Fañch

Sorry for the delay and thanks for all the details.

As far as I can see you are converting mov HD files. Please try converting some standard definition file of different format, for example avi, or wmv and see if multi-pass conversion works properly. If it does, there may be a problem working with certain source files. In that case please upload one of your mov HD files to our ftp server, instructions will be sent to you in our support system. Please login into it with your e-mail and password which have just been sent to your e-mail.

Looking forward to hearing from you.

Regards.
Posts: 38
Registered: 12.05.2011
15.06.11 05:31:57
All well-noted Vlad, thank you for the concern.

Please consider these new pieces of information :

- After having installed x264 video codec on my pc (H264 is present in my source files, thought it would help somehow to install that x264), multi-pass worked out fine; 2nd pass ran smoothly over the 1st.
- BUT that was unfortunately only true for one clip of 443 Mo (also .mov HD as you spoted out). Whenever I try it on a bigger file (the one I've got troubles with weighs 874 Mo), I got the same old error message.
- I ran a multipass test from an .avi (901 Mo) to .mkv, keeping all settings alike (ie. with low video/audio bitrates), and it worked out fine.

Could the issue originate from a too large file in both size & quality?

Upload of the problematic file is working its way up ; I'll post again as soon as it's done.

Regards.
Online:
Users:  0  
Guests:  275