AVS4You.comSupportRulesAbout Us
    ENG English    FRA Français    DEU Deutsch
Posts: 2
Registered: 16.05.2019
16.05.19 21:06:09
Hi,

Maybe I am doing something wrong here but it seems that the option to use your GPU to render the video does not work for me. (latest version AVS Video Editor 9.0.3.333)

I have a NVIDIA 1080 card and activated the option to use it for preview and conversion (also disabled the Intel option completely) but when rendering the video I can see that the GPU is not doing anything while the CPU still goes up to 100%.

Since GPU rendering is a lot faster, I really would like to use this feature.

I did uninstall the old version and installed the new version the way it is described here --> https://www.avs4you.com/guides/how-to-reinstall-avs4you-programs.aspx (uninstall + cleaning registry + folders)

Could you please let me know what I can do to get my videos rendered on my NVidia 1080 GPU ?

Kind reagrds,
paulp.
Developer
Posts: 215
Registered: 08.09.2009
17.05.19 16:21:06
To: paulp

If your computer has integrated GPU (Intel/AMD CPU with iGPU) and discrete GPU (NVIDIA), you need to assign the preferred graphics processor for AVS4YOU applications.

1. If your computer is a laptop then you can run NVIDIA Control Panel and assign the preferred graphics processor for AVS4YOU applications.
1.1) Run "NVIDIA Control Panel" (in Windows Control Panel, in Desktop Right Click Menu or by clicking "NVIDIA CUDA" picture in AVS Settings window).
1.2) Open "3D Settings" -> select "Manage 3D settings" -> open "Program Settings" tab -> click "Add" button in control group "1. Select a program to customize:" and add AVSVideoConverter.exe, AVSVideoEditor.exe, AVSVideoConverterHost.exe, AVSVideoReMaker.exe, AVSMediaPlayer.exe or AVSAudioEditor.exe.
1.3) Select the preferred graphics processor for this program - "High Performance NVIDIA processor" and click "Apply" button.

2. If your OS is Windows 10 v.1803, v.1809 or v.1903 then you can use Windows Settings.
2.1) Run Windows Settings.
2.2) Open "System" -> "Display" -> scroll down and click "Graphics settings" -> select "Classic app", click "Browse" button and add AVSVideoConverter.exe, AVSVideoEditor.exe, AVSVideoConverterHost.exe, AVSVideoReMaker.exe, AVSMediaPlayer.exe or AVSAudioEditor.exe.
2.3) Select added AVS4YOU application and click "Options" button -> select "High performance" and click "Save" button.

If you further need to use the iGPU (Intel HD Graphics) for AVS4YOU programs again, you will need to make the above settings, but choose a different processor (Integrated graphics, Power saving).
Posts: 2
Registered: 16.05.2019
24.05.19 18:39:14
To: RomanN


Thanks for the quick answer but it still does not seem to work for me.

Let me get into more details about my system:
I am running Windows 7 Prof.
I disabled the onboard Intel GPU 4600 in the BIOS on my Intel I7-4770 CPU.
There is an NVIDIA 1080 card in the PCI Express slot.

So I am only making use of the NVIDIA 1080 card. I used the NVidia control panel to select the 1080 for AVSVideoEditor.exe and AVSVideoConverterHost.exe. (just to be sure the program is linked, but it should run anyway as it is the only active GPU.)

I tried everything so far and it still uses 100% CPU and it will not render/preview my videos on the NVidia 1080 GPU.

Could it be that this feature does not work for Windows 7 ? Do I really need Win10 for this ?

Kind reagrds,
paulp.
Developer
Posts: 215
Registered: 08.09.2009
27.05.19 12:38:11
paulp:
Could it be that this feature does not work for Windows 7 ? Do I really need Win10 for this ?

We have tested NVIDIA CUDA support for some NVIDIA GPUs in Windows XP, 7, 8.1, 10 - it's alright.

What is the format and video codec of your input video files? Please, give us a sample file of small size.
Posts: 2
Registered: 13.07.2019
14.07.19 19:29:20
RomanN:
Dear users, we have published some instructions for setting up a hardware for video decoding with acceleration.

....
How to set NVIDIA® as a preferred graphics processor for the AVS4YOU applications on Windows 10?

]


To RomanN :

I have followed all the above procedures, including but not limited to , doing a clean re-install of AVS4YOU Video Editor 9.1, and I still get a blank screen in the project view window section of the app, when I import .mp4 files that I'm working on.

My PC is running, on Microsoft Windows 10 Home, Version: 10.0.17134 Build 17134, on Intel(R) Core(TM)i3 CPU, with an nvidia Geforce GTX 1050 Ti graphics card.

My AVS4YOU Video Editor app, has always worked fine, until I the following 2 upgrades were done to my PC:

1. Upgraded my graphics card to nvidia Geforce GTX 1050 Ti, updated the latter's drivers, to its latest, and;
2. Updated my AVS4YOU Video Editor, to the current version 9.1

To Everyone:

Is anybody experiencing blank screens just as I am, with the AVS4YOU Video Editor app running in combination with an nvidia Geforce card? Would appreciate your sharing your experience, and or, how you got the AVS4YOU Video Editor working again.

Would appreciate a feedback.
Developer
Posts: 215
Registered: 08.09.2009
16.07.19 07:40:53
To: bobbyprah@yahoo.com

Please check this option:
Settings -> Preview -> Video rendering = "Use video buffer" (recommended for Windows 10).

Also you can try to update your Windows 10 version 1803 Build 17134 to newer versions 1809 Build 17763 or 1903 Build 18362.
Posts: 2
Registered: 13.07.2019
16.07.19 17:31:42
RomanN:
To: bobbyprah@yahoo.com

Please check this option:
Settings -> Preview -> Video rendering = "Use video buffer" (recommended for Windows 10).


The above option, worked for me. Now, the blank screen has vanished, and my "AVS4YOU Video Editor" app, is working again, and the video rendering, as usual, works like a charm:-)

Thanks, RomanN
Online:
Users:  1  Gladys Vo
Guests:  294